aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-04-10 01:46:24 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-04-10 01:46:24 +0000
commit34037b162468fa1766452c56da3daac43ff03242 (patch)
treea657e7879aec71fb20e83c7a2f4db4035cb10f4b /configure.in
parented89013e68c3fef05346a0e06c7a43f0f299190d (diff)
downloadruby-34037b162468fa1766452c56da3daac43ff03242.tar.gz
configure.in: detect baseruby by default
* configure.in: default HAVE_BASERUBY to yes, for auto detection. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@58298 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 75ecfaf8eb..05915136e4 100644
--- a/configure.in
+++ b/configure.in
@@ -37,10 +37,11 @@ rm() {
{ # environment section
+HAVE_BASERUBY=yes
AC_ARG_WITH(baseruby,
AS_HELP_STRING([--with-baseruby=RUBY], [use RUBY as baseruby; RUBY is the pathname of ruby]),
[AS_CASE(["$withval"],
- [*ruby*],[BASERUBY=$withval; HAVE_BASERUBY=yes],
+ [*ruby*],[BASERUBY=$withval],
[no],[HAVE_BASERUBY=no],
[AC_MSG_ERROR(need ruby)])
],