aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-03-25 07:46:12 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-03-25 07:46:12 +0000
commite5f688d5cebb10d039946aabee7306b03c80a138 (patch)
tree7d603a7a3e73e58c1cefd661aa5c7feffd47d2c0 /configure.in
parent01bef4addde9c5eee8b2842be92d72692781a7a8 (diff)
downloadruby-e5f688d5cebb10d039946aabee7306b03c80a138.tar.gz
configure.in: syscall is deprecated on macOS
* configure.in: syscall is no longer supported on macOS since 10.12. [ruby-core:80300] [Bug #13361] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@58084 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1cec2e33ac..dcd56ba2f7 100644
--- a/configure.in
+++ b/configure.in
@@ -1100,6 +1100,12 @@ AS_CASE(["$target_os"],
],
[macosx_10_5=yes], [macosx_10_5=no])
AC_MSG_RESULT($macosx_10_5)
+ AS_IF([test "${target_os@%:@darwin}" -ge 16], [
+ ac_cv_func___syscall=no
+ ac_cv_func_syscall=no
+ ac_cv_header_sys_syscall_h=no
+ ac_cv_header_syscall_h=no
+ ])
if test $macosx_10_5 = yes; then
ac_cv_func_getcontext=no
ac_cv_func_setcontext=no