aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-06-11 05:36:56 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-06-11 05:36:56 +0000
commitf0995867968c2012d361ded386c970baa37c039c (patch)
treec06ca3e2ad4fe4d50b775948a277e863c646fb72 /configure.in
parent0e6505f42decf6a4ef0c5c2076172b119a01b238 (diff)
downloadruby-f0995867968c2012d361ded386c970baa37c039c.tar.gz
configure.in: link the DWARF debug information
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@59058 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 24035c7c1a..b846524fdc 100644
--- a/configure.in
+++ b/configure.in
@@ -1203,9 +1203,16 @@ main()
if test "$rb_cv_broken_crypt" = yes; then
AC_DEFINE(BROKEN_CRYPT, 1)
fi
+ POSTLINK=""
AC_CHECK_PROGS(codesign, codesign)
+ AC_CHECK_PROGS(dsymutil, dsymutil)
if test -n "$codesign"; then
- POSTLINK="test -z '\$(RUBY_CODESIGN)' || $codesign -s '\$(RUBY_CODESIGN)' -f \$@"
+ POSTLINK="{ test -z '\$(RUBY_CODESIGN)' || $codesign -s '\$(RUBY_CODESIGN)' -f \$@; }${POSTLINK:+; $POSTLINK}"
+ fi
+ if test -n "$dsymutil"; then
+ POSTLINK="$dsymutil \$@${POSTLINK:+; $POSTLINK}"
+ fi
+ if test -n "${POSTLINK}"; then
LINK_SO="$LINK_SO
\$(POSTLINK)"
fi