aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-04-10 01:22:49 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-04-10 01:22:49 +0000
commitf4de9234b28652a99dc0003fc2eaeea4903493f2 (patch)
treec0e41ee2c983b4b522cecefc1dd9ca152a2b7c4d /configure.in
parent80b13631bc16be93911287e227b1e4bf719b8fac (diff)
downloadruby-f4de9234b28652a99dc0003fc2eaeea4903493f2.tar.gz
Allow --without-baseruby option
* configure.in, win32/configure.bat: allow --without-baseruby option to use already generated files without baseruby. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@58296 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index c68a082be7..75ecfaf8eb 100644
--- a/configure.in
+++ b/configure.in
@@ -39,18 +39,19 @@ rm() {
AC_ARG_WITH(baseruby,
AS_HELP_STRING([--with-baseruby=RUBY], [use RUBY as baseruby; RUBY is the pathname of ruby]),
- [
- AS_CASE(["$withval"],[*ruby*],[BASERUBY=$withval],[AC_MSG_ERROR(need ruby)])
+ [AS_CASE(["$withval"],
+ [*ruby*],[BASERUBY=$withval; HAVE_BASERUBY=yes],
+ [no],[HAVE_BASERUBY=no],
+ [AC_MSG_ERROR(need ruby)])
],
[
AC_PATH_PROG([BASERUBY], [ruby], [false])
])
-if test "`RUBYOPT=- $BASERUBY -e 'print 42' 2>/dev/null`" = 42; then
+if test "$HAVE_BASERUBY" = yes -a "`RUBYOPT=- $BASERUBY -e 'print 42' 2>/dev/null`" = 42; then
if test "`RUBYOPT=- $BASERUBY --disable=gems -e 'print 42' 2>/dev/null`" = 42; then
BASERUBY="$BASERUBY --disable=gems"
fi
$BASERUBY -C "$srcdir/tool" downloader.rb -e gnu config.guess config.sub
- HAVE_BASERUBY=yes
else
BASERUBY="echo executable host ruby is required. use --with-baseruby option.; false"
HAVE_BASERUBY=no