aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a101b2110e..8db1c90701 100644
--- a/configure.ac
+++ b/configure.ac
@@ -543,6 +543,7 @@ AS_IF([test "$GCC" = yes], [
])
AS_IF([test "x$compress_debug_sections" != xno], [
RUBY_APPEND_OPTION(DLDFLAGS, ${linker_flag}--compress-debug-sections=$compress_debug_sections)
+ RUBY_APPEND_OPTION(MJIT_DLDFLAGS_NOCOMPRESS, ${linker_flag}--compress-debug-sections=no)
])
AS_CASE(["$target_os"],[mingw*], [
@@ -2470,6 +2471,7 @@ AC_SUBST(MJIT_CC, [${MJIT_CC-'$(CC)'}])dnl
AC_SUBST(MJIT_OPTFLAGS, [${MJIT_OPTFLAGS-'$(optflags)'}])dnl
AC_SUBST(MJIT_DEBUGFLAGS, [${MJIT_DEBUGFLAGS-'$(debugflags)'}])dnl
AC_SUBST(MJIT_LDSHARED)dnl
+AC_SUBST(MJIT_DLDFLAGS_NOCOMPRESS)dnl
AC_SUBST(STATIC)dnl
AC_SUBST(CCDLFLAGS)dnl