aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2230e188fe..6c8311dbe8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -579,8 +579,9 @@ AS_IF([test "$GCC" = yes], [
AS_HELP_STRING([--disable-fortify-source],
[disable -D_FORTIFY_SOURCE=2 option, which causes link error on mingw]),
[fortify_source=$enableval])
- test "x$fortify_source" = xno ||
+ AS_IF([test "x$fortify_source" = xno], [
RUBY_TRY_CFLAGS(-D_FORTIFY_SOURCE=2, [RUBY_APPEND_OPTION(XCFLAGS, -D_FORTIFY_SOURCE=2)])
+ ])
: ${MJIT_HEADER_FLAGS='-P -dD'}