aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 375ef5533c..5ae7f69cc8 100644
--- a/configure.in
+++ b/configure.in
@@ -3241,7 +3241,12 @@ AC_ARG_WITH(ext,
[pass to --with-ext option of extmk.rb]))
AC_ARG_WITH(out-ext,
AC_HELP_STRING([--with-out-ext=EXTS],
- [pass to --without-ext option of extmk.rb]))
+ [pass to --without-ext option of extmk.rb]),
+ [], [
+ AS_CASE($target_os,
+ [mswin*|mingw*],
+ [as_fn_append ac_configure_args ' --with-out-ext=pty,readline,syslog'],
+ [as_fn_append ac_configure_args ' --with-out-ext=*win32*'])])
EXTSTATIC=
AC_SUBST(EXTSTATIC)dnl
AC_ARG_WITH(static-linked-ext,