aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 8904ff89a5..1bfe6dc71a 100644
--- a/configure.in
+++ b/configure.in
@@ -1534,11 +1534,12 @@ case "$target_os" in
changequote(<<, >>)dnl
<<
#include <stdio.h>
-main ()
+int
+main()
{
char buf[256];
- sprintf (buf, "%g", 1e+300);
- exit (strcmp (buf, "1e+300") ? 0 : 1);
+ sprintf(buf, "%g", 1e+300);
+ return (strcmp (buf, "1e+300") ? 0 : 1);
}
>>,
changequote([, ])dnl
@@ -1553,11 +1554,12 @@ changequote(<<, >>)dnl
<<
#include <stdio.h>
#include <math.h>
-main ()
+int
+main()
{
char buf[256];
- sprintf (buf, "%f", log(exp(1.0)));
- exit (strcmp (buf, "1.000000") ? 0 : 1);
+ sprintf(buf, "%f", log(exp(1.0)));
+ return (strcmp (buf, "1.000000") ? 0 : 1);
}
>>,
changequote([, ])dnl