aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 4b7fb581c9..e051cb6cfe 100644
--- a/configure.in
+++ b/configure.in
@@ -2267,9 +2267,13 @@ AS_CASE("$enable_shared", [yes], [
SOLIBS='$(LIBS)'
fi
- if test "$GCC" = yes; then
- RUBY_TRY_LDFLAGS([-Xlinker --no-undefined], RUBY_APPEND_OPTION(EXTLDFLAGS, [-Xlinker --no-undefined]))
- fi
+ AS_CASE(["$target_os"],
+ [freebsd*], ,
+ [
+ if test "$GCC" = yes; then
+ RUBY_TRY_LDFLAGS([-Xlinker --no-undefined], RUBY_APPEND_OPTION(EXTLDFLAGS, [-Xlinker --no-undefined]))
+ fi
+ ])
AS_CASE(["$target_os"],
[sunos4*], [