aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ce4ea18a29..f7a2c05a7c 100644
--- a/configure.in
+++ b/configure.in
@@ -2271,7 +2271,10 @@ AS_CASE("$enable_shared", [yes], [
[freebsd*|dragonfly*], [],
[
if test "$GCC" = yes; then
- RUBY_TRY_LDFLAGS([-Xlinker --no-undefined], RUBY_APPEND_OPTION(EXTLDFLAGS, [-Xlinker --no-undefined]))
+ RUBY_TRY_LDFLAGS([-Wl,--no-undefined], [no_undefined=yes], [no_undefined=no])
+ if test "no_undefined" = yes; then
+ RUBY_APPEND_OPTION(EXTLDFLAGS, [-Wl,--no-undefined])
+ fi
fi
])