aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 83fad09a4c..6783b82994 100644
--- a/configure.in
+++ b/configure.in
@@ -1457,7 +1457,7 @@ if test "$with_dln_a_out" != yes; then
hiuxmpp) : ${LDSHARED='ld -r'} ;;
atheos*) : ${LDSHARED="$CC -shared"}
rb_cv_dlopen=yes ;;
- os2-emx*) LDFLAGS="$LDFLAGS -Zbsd-signals"
+ os2-emx*) LDFLAGS="$LDFLAGS -Zomf"
;;
*) : ${LDSHARED='ld'} ;;
esac
@@ -1801,7 +1801,7 @@ case "$target_os" in
MINIDLNOBJ=dmydln.o
;;
os2-emx)
- CFLAGS="$CFLAGS -DOS2 -Zmts"
+ CFLAGS="$CFLAGS -DOS2"
LIBRUBY_A=`echo $LIBRUBY_A | sed 's/^lib//'`
LIBRUBY_SO=`echo $LIBRUBY_SO | sed 's/^lib//'`
LIBRUBY_ALIASES=`for i in $LIBRUBY_ALIASES; do echo "$i"; done | sed 's/^lib//'`