aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a3d191a2bf..5e1c479c12 100644
--- a/configure.in
+++ b/configure.in
@@ -289,6 +289,11 @@ AC_PROG_CXX
AC_PROG_GCC_TRADITIONAL
AC_SUBST(GCC)
if test "$GCC" = yes; then
+ AC_TRY_LINK([
+ @%:@if defined __llvm__ && !defined __clang__
+ @%:@error llvm-gcc has ended
+ @%:@endif
+ ], [], [], [AC_MSG_ERROR(llvm-gcc has ended)])
linker_flag=-Wl,
: ${optflags=-O3}
AS_CASE(["$target_os"], [linux*|darwin*], [: ${debugflags=-ggdb}])