aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0feaa29ab8..a9b1874bfb 100644
--- a/configure.in
+++ b/configure.in
@@ -218,6 +218,13 @@ fi
dnl check for large file stuff
AC_SYS_LARGEFILE
+case "$target_os" in
+mingw*)
+ ac_cv_type_off_t=yes
+ ac_cv_sizeof_off_t=8
+ ;;
+esac
+
AC_CHECK_TYPES([long long, off_t])
AC_CHECK_SIZEOF(int, 4)
@@ -378,6 +385,9 @@ mingw*) LIBS="-lshell32 -lws2_32 $LIBS"
ac_cv_func_isnan=yes
ac_cv_func_finite=yes
ac_cv_func_link=yes
+ ac_cv_func_truncate=yes
+ ac_cv_func_fseeko=yes
+ ac_cv_func_ftello=yes
ac_cv_lib_crypt_crypt=no
ac_cv_func_getpgrp_void=no
ac_cv_func_setpgrp_void=yes