aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ab53e8a2c2..e94b3d6309 100644
--- a/configure.in
+++ b/configure.in
@@ -617,6 +617,11 @@ if test "$GCC" = yes; then
# comments. We bypass ANSI C mode for them. Otherwise
# extension libs cannot include those headers.
],
+ [cygwin*], [
+ # needs C99 to isinf() and so on
+ RUBY_APPEND_OPTION(warnflags, -ansi -std=c99)
+ RUBY_APPEND_OPTION(rb_cv_warnflags, -ansi -std=c99)
+ ],
[
# ANSI (no XCFLAGS because this is C only)
RUBY_TRY_CFLAGS(-ansi -std=iso9899:199409, [