aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 63a88bc3f7..3a1999c78c 100644
--- a/configure.in
+++ b/configure.in
@@ -194,8 +194,8 @@ if test ${target_archs+set}; then
else
if test x"$target_cpu" != x"${target_archs}"; then
echo 'int main(){return 0;}' > conftest.c
- if $CC $CFLAGS $ARCH_FLAG conftest.c > /dev/null 2>&1; then
- rm -f conftest.* a.out
+ if $CC $CFLAGS $ARCH_FLAG -o conftest conftest.c > /dev/null 2>&1; then
+ rm -fr conftest.*
else
RUBY_DEFAULT_ARCH("$target_archs")
fi