aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 4ab2446e73..aeb8ddf6fb 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT()
-AC_PREREQ(2.58)
+AC_PREREQ(2.60)
AC_ARG_WITH(baseruby,
[ --with-baseruby=RUBY use RUBY as baseruby; RUBY is the pathname of ruby],
@@ -243,8 +243,7 @@ AC_PROG_MAKE_SET
AC_PROG_INSTALL
# checks for UNIX variants that set C preprocessor variables
-AC_AIX
-AC_MINIX
+AC_USE_SYSTEM_EXTENSIONS
AC_SUBST(RM, ['rm -f'])
AC_SUBST(CP, ['cp'])
@@ -1624,7 +1623,6 @@ fi
MINIDLNOBJ=dln.o
case "$target_os" in
linux*)
- XCFLAGS="$XCFLAGS -D_GNU_SOURCE=1"
;;
netbsd*)
CFLAGS="$CFLAGS -pipe"