aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e71aeb3c03..1e1b2ac9fc 100644
--- a/configure.in
+++ b/configure.in
@@ -549,7 +549,9 @@ if test "$GCC" = yes; then
])
# disable fast-math
- RUBY_TRY_CFLAGS(-fno-fast-math, [RUBY_APPEND_OPTION(optflags, $oflag)])
+ for oflag in -fno-fast-math; do
+ RUBY_TRY_CFLAGS(oflag, [RUBY_APPEND_OPTION(optflags, $oflag)])
+ done
fi
test -z "${ac_env_CFLAGS_set}" -a -n "${cflags+set}" && eval CFLAGS="\"$cflags $ARCH_FLAG\""