aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index f7fa8a9ad6..8ec9bed5cc 100644
--- a/configure.in
+++ b/configure.in
@@ -828,7 +828,7 @@ case "$target_os" in
LIBRUBY_SO='$(RUBY_INSTALL_NAME)-'$target_os.dll
LIBRUBY_DLDFLAGS='--dllname=$@ --output-lib=$(LIBRUBY) --add-stdcall-alias --def=$(RUBYDEF)'
else
- LIBRUBY_SO=nul
+ LIBRUBY_SO=dummy
LIBRUBY_DLDFLAGS='--output-exp=$(RUBY_INSTALL_NAME).exp --dllname=$(RUBY_INSTALL_NAME)$(EXEEXT) --output-lib=$(LIBRUBY) --add-stdcall-alias --def=$(RUBYDEF)'
fi
LIBRUBY_ALIASES=''
@@ -836,6 +836,7 @@ case "$target_os" in
LIBRUBY='lib$(RUBY_INSTALL_NAME).a'
LIBRUBYARG='-L. -l$(RUBY_INSTALL_NAME)'
FIRSTMAKEFILE=GNUmakefile:cygwin/GNUmakefile.in
+ SOLIBS='$(LIBS)'
case "$target_os" in
cygwin*)
LIBOBJS="$LIBOBJS strftime.o"
@@ -843,8 +844,7 @@ case "$target_os" in
mingw*)
LIBOBJS="$LIBOBJS win32.o"
CFLAGS="-DNT -D__MSVCRT__ $CFLAGS"
- CCDLFLAGS=-DIMPORT
- SOLIBS='$(LIBS)' ;;
+ CCDLFLAGS=-DIMPORT ;;
esac
;;
*)