aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTomas Hlavacek <tmshlvck@gmail.com>2013-02-24 23:47:22 +0100
committerTomas Hlavacek <tmshlvck@gmail.com>2013-03-19 18:03:49 +0100
commit8322ecde124188a9408b54afead4666bb954e5a5 (patch)
treef34cc23ed221714974475ce95ad2abbf7954b16e /configure.in
parente454916149d4efe66732fdd0388181813cab6ed0 (diff)
downloadbird-8322ecde124188a9408b54afead4666bb954e5a5.tar.gz
Add lightweight client - birdcl
Restructure client/ subdir. Add two different flavors of client. The full featured birdc client code is in client/birdc/. The new light client birtcl is in client/birdcl/. Common sources of both clients are directly in client/. Rework on-line auto-completion in client/command.c to conditionally turn off ncurses-specific code. Add lightweight client without libreadline and ncurses dependencies - birdcl. The birdcl lacks support of history, on-line auto-completion and there are different implementations of "more" functionality and help on '?' press. New client operates in canonical terminal mode (apart from "more" display) and therefore all commands have to be executed by a return key including help commands (called by '?' character in the end of the line). Apart from these limitations the interaction style should be the same as for the full client - birdc. Build of birdcl is always on (independent on --enable-client parameter).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 54993dfc..534baf21 100644
--- a/configure.in
+++ b/configure.in
@@ -234,7 +234,7 @@ fi
CLIENT=
CLIENT_LIBS=
if test "$enable_client" = yes ; then
- CLIENT=client
+ CLIENT=birdc
AC_CHECK_LIB(history, add_history, CLIENT_LIBS="-lhistory")
AC_CHECK_LIB(ncurses, tgetent, USE_TERMCAP_LIB=-lncurses,
AC_CHECK_LIB(curses, tgetent, USE_TERMCAP_LIB=-lcurses,