aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorOndrej Zajicek <santiago@crfreenet.org>2013-04-17 15:09:50 +0200
committerOndrej Zajicek <santiago@crfreenet.org>2013-04-17 15:09:50 +0200
commitefd6d12b975441c7e1875a59dd9e0f3db7e958cb (patch)
treefccf3a5cf753b0f1a168031329278965bfc4f3eb /configure.in
parent8df02847e8af29863c325b7297e3a2b2ed5f961c (diff)
downloadbird-efd6d12b975441c7e1875a59dd9e0f3db7e958cb.tar.gz
Adds two new default GCC options.
Adds two new default GCC options related to optimizations (-fno-strict-aliasing and -fno-strict-overflow). This should fix some hyperaggressive GCC optimizations. Also updates autoconf option detection.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 54993dfc..272a2431 100644
--- a/configure.in
+++ b/configure.in
@@ -87,15 +87,17 @@ if test -z "$GCC" ; then
AC_MSG_ERROR([This program requires the GNU C Compiler.])
fi
-AC_MSG_CHECKING([what CFLAGS should we use])
if test "$bird_cflags_default" = yes ; then
- BIRD_CHECK_GCC_OPTIONS
+ BIRD_CHECK_GCC_OPTION(bird_cv_c_option_wno_pointer_sign, -Wno-pointer-sign, -Wall)
+ BIRD_CHECK_GCC_OPTION(bird_cv_c_option_fno_strict_aliasing, -fno-strict-aliasing)
+ BIRD_CHECK_GCC_OPTION(bird_cv_c_option_fno_strict_overflow, -fno-strict-overflow)
CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wno-parentheses"
- if test "$bird_cv_c_option_no_pointer_sign" = yes ; then
- CFLAGS="$CFLAGS -Wno-pointer-sign"
- fi
+ BIRD_ADD_GCC_OPTION(bird_cv_c_option_wno_pointer_sign, -Wno-pointer-sign)
+ BIRD_ADD_GCC_OPTION(bird_cv_c_option_fno_strict_aliasing, -fno-strict-aliasing)
+ BIRD_ADD_GCC_OPTION(bird_cv_c_option_fno_strict_overflow, -fno-strict-overflow)
fi
+AC_MSG_CHECKING([CFLAGS])
AC_MSG_RESULT($CFLAGS)