summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2022-07-14 12:53:46 +0200
committerBen Hutchings <benh@debian.org>2022-07-14 12:53:46 +0200
commit1b933706178602c7b5b40dac85356511c69657a7 (patch)
treea23233223cd0ca8f7c065134cd269b8039a914d7
parentd597220b33ec82a9596e1e10a5b8c08e6e155317 (diff)
downloadlinux-debian-1b933706178602c7b5b40dac85356511c69657a7.tar.gz
[i386] x86/asm/32: Fix ANNOTATE_UNRET_SAFE use on 32-bit (fixes FTBFS)
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/bugfix/x86/retbleed/0056-x86-asm-32-fix-annotate_unret_safe-use-on-32-bit.patch36
-rw-r--r--debian/patches/series1
3 files changed, 43 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 8dc00d9cb..a35300d0d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+linux (5.19~rc6-1~exp2) UNRELEASED; urgency=medium
+
+ * [i386] x86/asm/32: Fix ANNOTATE_UNRET_SAFE use on 32-bit (fixes FTBFS)
+
+ -- Ben Hutchings <benh@debian.org> Thu, 14 Jul 2022 12:52:40 +0200
+
linux (5.19~rc6-1~exp1) experimental; urgency=medium
* New upstream release candidate
diff --git a/debian/patches/bugfix/x86/retbleed/0056-x86-asm-32-fix-annotate_unret_safe-use-on-32-bit.patch b/debian/patches/bugfix/x86/retbleed/0056-x86-asm-32-fix-annotate_unret_safe-use-on-32-bit.patch
new file mode 100644
index 000000000..2ba7abb8a
--- /dev/null
+++ b/debian/patches/bugfix/x86/retbleed/0056-x86-asm-32-fix-annotate_unret_safe-use-on-32-bit.patch
@@ -0,0 +1,36 @@
+From: Jiri Slaby <jslaby@suse.cz>
+Date: Wed, 13 Jul 2022 11:50:46 +0200
+Subject: x86/asm/32: Fix ANNOTATE_UNRET_SAFE use on 32-bit
+Origin: https://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git/commit?id=3131ef39fb03bbde237d0b8260445898f3dfda5b
+
+The build on x86_32 currently fails after commit
+
+ 9bb2ec608a20 (objtool: Update Retpoline validation)
+
+with:
+
+ arch/x86/kernel/../../x86/xen/xen-head.S:35: Error: no such instruction: `annotate_unret_safe'
+
+ANNOTATE_UNRET_SAFE is defined in nospec-branch.h. And head_32.S is
+missing this include. Fix this.
+
+Fixes: 9bb2ec608a20 ("objtool: Update Retpoline validation")
+Signed-off-by: Jiri Slaby <jslaby@suse.cz>
+Signed-off-by: Borislav Petkov <bp@suse.de>
+Link: https://lore.kernel.org/r/63e23f80-033f-f64e-7522-2816debbc367@kernel.org
+---
+ arch/x86/kernel/head_32.S | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/arch/x86/kernel/head_32.S b/arch/x86/kernel/head_32.S
+index eb8656bac99b..9b7acc9c7874 100644
+--- a/arch/x86/kernel/head_32.S
++++ b/arch/x86/kernel/head_32.S
+@@ -23,6 +23,7 @@
+ #include <asm/cpufeatures.h>
+ #include <asm/percpu.h>
+ #include <asm/nops.h>
++#include <asm/nospec-branch.h>
+ #include <asm/bootparam.h>
+ #include <asm/export.h>
+ #include <asm/pgtable_32.h>
diff --git a/debian/patches/series b/debian/patches/series
index da8dd6932..5e3d03519 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -153,6 +153,7 @@ bugfix/x86/retbleed/0052-x86-bugs-Do-not-enable-IBPB-on-entry-when-IBPB-is-no.pa
bugfix/x86/retbleed/0053-x86-kexec-Disable-RET-on-kexec.patch
bugfix/x86/retbleed/0054-x86-speculation-Disable-RRSBA-behavior.patch
bugfix/x86/retbleed/0055-x86-static_call-Serialize-__static_call_fixup-proper.patch
+bugfix/x86/retbleed/0056-x86-asm-32-fix-annotate_unret_safe-use-on-32-bit.patch
# Fix exported symbol versions
bugfix/all/module-disable-matching-missing-version-crc.patch