summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2022-07-29 00:50:20 +0200
committerBen Hutchings <benh@debian.org>2022-07-29 00:50:20 +0200
commit3ceaf96bf636f93ce02f96097cce2c2f9b36c0f6 (patch)
treea53daf35b3a1b253d484741283a66917496f21ba
parente936f58896f77c0581b3eb0a3c2c6cbb4e97a227 (diff)
downloadlinux-debian-3ceaf96bf636f93ce02f96097cce2c2f9b36c0f6.tar.gz
d/tests: Run kbuild test with default flavour if quick flavour not defined
ci.debian.net runs tests on most release architectures. Currently the kbuild script quietly fails on any architecture where a quick flavour is not defined. Use the default flavour if there is no quick flavour. There are still some architectures where neither is defined, so this isn't a complete fix.
-rwxr-xr-xdebian/bin/gencontrol.py2
-rw-r--r--debian/changelog1
-rw-r--r--debian/tests/kbuild2
3 files changed, 3 insertions, 2 deletions
diff --git a/debian/bin/gencontrol.py b/debian/bin/gencontrol.py
index d1dbad26c..b6bed381c 100755
--- a/debian/bin/gencontrol.py
+++ b/debian/bin/gencontrol.py
@@ -569,7 +569,7 @@ class Gencontrol(Base):
self.tests_control_image = tests_control
self.tests_control.append(tests_control)
- if flavour == self.quick_flavour:
+ if flavour == (self.quick_flavour or self.default_flavour):
tests_control = self.process_package(
self.templates['tests-control.headers'][0], vars)
tests_control['Depends'].append(
diff --git a/debian/changelog b/debian/changelog
index c2060728e..4ee90c2cf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
linux (5.18.14-2) UNRELEASED; urgency=medium
* d/tests: kbuild test case depends on python3
+ * d/tests: Run kbuild test with default flavour if quick flavour not defined
-- Ben Hutchings <benh@debian.org> Fri, 29 Jul 2022 00:43:54 +0200
diff --git a/debian/tests/kbuild b/debian/tests/kbuild
index b6797e397..2634c17e4 100644
--- a/debian/tests/kbuild
+++ b/debian/tests/kbuild
@@ -24,7 +24,7 @@ obj-m += foo.o
EOF
arch="$(dpkg --print-architecture)"
-release="$(debian/bin/getconfig.py version abiname)-$(debian/bin/getconfig.py base $arch none quick-flavour)"
+release="$(debian/bin/getconfig.py version abiname)-$(debian/bin/getconfig.py base $arch none quick-flavour || debian/bin/getconfig.py base $arch none default-flavour)"
echo "I: Build for $release"
# There are some warnings sent to stderr that we need to suppress,