summaryrefslogtreecommitdiffstats
path: root/debian/changelog
diff options
context:
space:
mode:
Diffstat (limited to 'debian/changelog')
-rw-r--r--debian/changelog34
1 files changed, 33 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 5612d9d32..3478a0fcd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-linux (5.4.4-1~exp1) UNRELEASED; urgency=medium
+linux (5.4.5-1~exp1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.4.3
@@ -246,6 +246,38 @@ linux (5.4.4-1~exp1) UNRELEASED; urgency=medium
- blk-mq: make sure that line break can be printed
- workqueue: Fix missing kfree(rescuer) in destroy_workqueue()
- r8169: fix rtl_hw_jumbo_disable for RTL8168evl
+ https://www.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.4.5
+ - inet: protect against too small mtu values.
+ - mqprio: Fix out-of-bounds access in mqprio_dump
+ - net: bridge: deny dev_set_mac_address() when unregistering
+ - net: dsa: fix flow dissection on Tx path
+ - [armhf] net: ethernet: ti: cpsw: fix extra rx interrupt
+ - net: sched: fix dump qlen for sch_mq/sch_mqprio with NOLOCK subqueues
+ - net_sched: validate TCA_KIND attribute in tc_chain_tmplt_add()
+ - [arm64] net: thunderx: start phy before starting autonegotiation
+ - openvswitch: support asymmetric conntrack
+ - tcp: md5: fix potential overestimation of TCP option space
+ - tipc: fix ordering of tipc module init and exit routine
+ - net/mlx5e: Query global pause state before setting prio2buffer
+ - net: ipv6: add net argument to ip6_dst_lookup_flow
+ - net: ipv6_stub: use ip6_dst_lookup_flow instead of ip6_dst_lookup
+ - tcp: fix rejected syncookies due to stale timestamps
+ - tcp: tighten acceptance of ACKs not matching a child socket
+ - tcp: Protect accesses to .ts_recent_stamp with {READ,WRITE}_ONCE()
+ - net: core: rename indirect block ingress cb function
+ - net: sched: allow indirect blocks to bind to clsact in TC
+ - cls_flower: Fix the behavior using port ranges with hw-offload
+ - gre: refetch erspan header from skb->data after pskb_may_pull()
+ - Fixed updating of ethertype in function skb_mpls_pop
+ - net: Fixed updating of ethertype in skb_mpls_push()
+ - net/mlx5e: Fix TXQ indices to be sequential
+ - net/mlx5e: Fix SFF 8472 eeprom length
+ - net/mlx5e: Fix freeing flow with kfree() and not kvfree()
+ - net/mlx5e: Fix translation of link mode into speed
+ - net/mlx5e: ethtool, Fix analysis of speed setting
+ - page_pool: do not release pool until inflight == 0.
+ - xdp: obtain the mem_id mutex before trying to remove an entry.
+ - r8169: add missing RX enabling for WoL on RTL8125
[ Ben Hutchings ]
* [armel/rpi,armhf,arm64] Enable DEBUG_WX