aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-09-21 13:52:03 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-09-21 13:52:03 +0000
commit03b3d70daae730c37e835766a480024efa40da7f (patch)
tree40b80fb97e54f8e99341525abc9164b2cc59cd1b /configure.ac
parentc0c3988f03b7cd6738c1f9dcf8fe5016a0907f40 (diff)
downloadruby-03b3d70daae730c37e835766a480024efa40da7f.tar.gz
configure.ac: prepend the wrapper after CPP is set
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@64809 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 15 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 815f8e30d5..900cd28402 100644
--- a/configure.ac
+++ b/configure.ac
@@ -211,18 +211,6 @@ AS_CASE(["$build_os"],
[xcc|x/usr/bin/cc], [: ${CXX=c++}],
[xicc], [: ${CXX=icpc}],
[xclang|x/usr/bin/clang], [: ${CXX=clang++}])
-
- # Xcode linker warns for deprecated architecture and wrongly
- # installed TBD files.
- CC_WRAPPER=""
- AS_IF([! $CC -E -xc - <<SRC >/dev/null 2>&1], [
- @%:@if defined __APPLE_CC__ && defined __clang_major__ && __clang_major__ >= 10
- @%:@error ignore linker warnings
- @%:@endif
-SRC
- CC_WRAPPER=`PWD=; cd "$srcdir/tool" && pwd`/darwin-cc
- CC="$CC_WRAPPER $CC"
- ])
])
test -z "$CXX" || ac_cv_prog_CXX="$CXX"
@@ -260,6 +248,21 @@ AC_SUBST(OUTFLAG)
AC_SUBST(COUTFLAG)
AC_SUBST(CSRCFLAG)
+AS_CASE(["$build_os"],
+ [darwin1*.*], [
+ # Xcode linker warns for deprecated architecture and wrongly
+ # installed TBD files.
+ CC_WRAPPER=""
+ AS_IF([! $CC -E -xc - <<SRC >/dev/null 2>&1], [
+ @%:@if defined __APPLE_CC__ && defined __clang_major__ && __clang_major__ >= 10
+ @%:@error ignore linker warnings
+ @%:@endif
+SRC
+ CC_WRAPPER=`PWD=; cd "$srcdir/tool" && pwd`/darwin-cc
+ CC="$CC_WRAPPER $CC"
+ ])
+ ])
+
cc_version=
for option in --version -v -V -qversion; do
cc_version_message=`$CC $option 2>&1`