aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Evans <code@jeremyevans.net>2021-08-13 08:16:24 -0700
committerJeremy Evans <code@jeremyevans.net>2021-10-08 14:01:54 -0900
commit06c3e80611b81ec8f251957328486e9b6dd18d3b (patch)
treec2c35a3f74d1f1aa76dae5f26ebf94ec1e21b3ca /configure.ac
parentb4afedb0dd6395ea18135e87351b02e99a12d8a3 (diff)
downloadruby-06c3e80611b81ec8f251957328486e9b6dd18d3b.tar.gz
Do not allow configuration where neither static or shared library is installed
Fixes [Bug #18000]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fc9a9967f3..e581d9ae12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3678,7 +3678,10 @@ AC_SUBST(MJIT_SUPPORT)
AC_ARG_ENABLE(install-static-library,
AS_HELP_STRING([--disable-install-static-library], [do not install static ruby library]),
- [INSTALL_STATIC_LIBRARY=$enableval],
+ [INSTALL_STATIC_LIBRARY=$enableval
+ AS_IF([test x"$enable_shared" = xno -a x"$INSTALL_STATIC_LIBRARY" = xno],
+ [AC_MSG_ERROR([must install either static or shared library])],
+ [])],
AS_IF([test x"$enable_shared" = xyes],
[INSTALL_STATIC_LIBRARY=no],
[INSTALL_STATIC_LIBRARY=yes]))