aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Wu <XrXr@users.noreply.github.com>2023-01-12 18:38:00 -0500
committerAlan Wu <XrXr@users.noreply.github.com>2023-01-27 12:28:09 -0500
commit17c8bf2c63192036058b03a04edf7a8478e47833 (patch)
treed4fad4d55eda0c9838fd8f50fa20bcce9c8a2288 /configure.ac
parent47b66a5acd1511089ac9585371d93e1b5ea07232 (diff)
downloadruby-17c8bf2c63192036058b03a04edf7a8478e47833.tar.gz
configure: Don't use use LD=clang, ld takes different flags
This was a difference from using a GNU toolchain previously. It wasn't a problem because we don't invoke $(LD) in the Makefile currently. YJIT will want to invoke LD, so needs this consistency.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 39e7fd831b..652a1fc153 100644
--- a/configure.ac
+++ b/configure.ac
@@ -214,7 +214,7 @@ AS_CASE(["/${rb_CC} "],
[*clang*], [
# Ditto for LLVM. Note however that llvm-as is a LLVM-IR to LLVM bitcode
# assembler that does not target your machine native binary.
- : ${LD:="${CC}"} # ... try -fuse-ld=lld ?
+ RUBY_CHECK_PROG_FOR_CC([LD], [s/clang/ld/]) # ... maybe try lld ?
RUBY_CHECK_PROG_FOR_CC([AR], [s/clang/llvm-ar/])
# RUBY_CHECK_PROG_FOR_CC([AS], [s/clang/llvm-as/])
RUBY_CHECK_PROG_FOR_CC([CXX], [s/clang/clang++/])