aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Hamilton <benhamilton@google.com>2023-02-23 13:31:53 -0700
committerAaron Patterson <aaron.patterson@gmail.com>2023-11-09 12:24:01 +0900
commit1d5598fe0d3470e7cab06a756d40a9221fcd501b (patch)
tree61f2e96db175d16ddd1bbc140e6235a3fd46b830 /configure.ac
parenta168426881480e0f07d75c5f830fb749c3b05249 (diff)
downloadruby-1d5598fe0d3470e7cab06a756d40a9221fcd501b.tar.gz
Disable iseq-dumped builtin module for universal x86_64/arm64 binaries
During the build, Ruby has special logic to serialize its own builtin module to disk using the binary iseq format during the build (I assume for speed so it doesn't have to parse builtin every time it starts up). However, since iseq format is architecture-specific, when building on x86_64 for universal x86_64 + arm64, the serialized builtin module is written with the x86_64 architecture of the build machine, which fails this check whenever ruby imports the builtin module on arm64: https://github.com/ruby/ruby/blob/1fdaa0666086529b3aae2d509a2e71c4247c3a12/compile.c#L13243 Thankfully, there's logic to disable this feature for cross-compiled builds: https://github.com/ruby/ruby/blob/1fdaa0666086529b3aae2d509a2e71c4247c3a12/builtin.c#L6 This disables the iseq logic for universal builds as well. Fixes [Bug #18286]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bf6d9af1f1..2ac47609fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4367,6 +4367,8 @@ AS_IF([test "${universal_binary-no}" = yes ], [
AC_DEFINE_UNQUOTED(RUBY_PLATFORM_OS, "${target_os}")
AC_DEFINE_UNQUOTED(RUBY_ARCH, "universal-" RUBY_PLATFORM_OS)
AC_DEFINE_UNQUOTED(RUBY_PLATFORM, "universal." RUBY_PLATFORM_CPU "-" RUBY_PLATFORM_OS)
+ AC_DEFINE(UNIVERSAL_BINARY, 1)
+ AC_SUBST(UNIVERSAL_BINARY, yes)
], [
AS_IF([test "${target_os}-${rb_cv_msvcrt}" = "mingw32-ucrt" ], [
arch="${target_cpu}-mingw-ucrt"