aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorshyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-10-03 04:49:34 +0000
committershyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-10-03 04:49:34 +0000
commit1f8dc01422770b4ca02877b07fe5a777c0b86462 (patch)
tree2dec77ed7c4fda30d457ea8b24b42e7c166e23b9 /configure.ac
parent6cc5d90918d7d8f20b2cf0ee8a189d8244b7f73b (diff)
downloadruby-1f8dc01422770b4ca02877b07fe5a777c0b86462.tar.gz
support --with-arch=x86_64h
Recent apple machines describe themselves being x86_64h. That architecture is somehow supported by their C compiler and at least by recent clang. However config.sub does not know that fact so making universal binary targeting it is rejected by the program. Why not skip the check by config.sub. [fix GH-1971] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@64905 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 367a072720..fb7c5c97d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3687,7 +3687,7 @@ AS_IF([test "${universal_binary-no}" = yes ], [
for archs in ${universal_archnames}; do
cpu=`echo $archs | sed 's/.*=//'`
archs=`echo $archs | sed 's/=.*//'`
- RUBY_DEFINE_IF([defined __${archs}__], RUBY_PLATFORM_CPU, ["${cpu}"])
+ RUBY_DEFINE_IF([defined __${archs}__ &&! defined RUBY_PLATFORM_CPU], RUBY_PLATFORM_CPU, ["${cpu}"])
done
])
ints='long int short'