aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authork0kubun <k0kubun@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-08-12 15:13:06 +0000
committerk0kubun <k0kubun@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-08-12 15:13:06 +0000
commit23cbcbc71e048360658b58a9741070b1e335926a (patch)
tree3e323a8dc7521350f5c45a0f9c3f43f62474f342 /configure.ac
parent52bf39645ed3645635c3ca7ebeff82e0653e6b94 (diff)
downloadruby-23cbcbc71e048360658b58a9741070b1e335926a.tar.gz
configure.ac: MJIT_DLDFLAGS_NOCOMPRESS
is configured now, to force -Wl,--compress-debug-sections=no for MJIT only when the option is used in MJIT_DLDFLAGS. This needs to be done in configure.ac to resolve build failure like https://travis-ci.org/ruby/ruby/builds/415120662. Makefile.in: define it in mjit_config.h mjit_worker.c: replace hard-coded flag to MJIT_DLDFLAGS_NOCOMPRESS git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@64325 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a101b2110e..8db1c90701 100644
--- a/configure.ac
+++ b/configure.ac
@@ -543,6 +543,7 @@ AS_IF([test "$GCC" = yes], [
])
AS_IF([test "x$compress_debug_sections" != xno], [
RUBY_APPEND_OPTION(DLDFLAGS, ${linker_flag}--compress-debug-sections=$compress_debug_sections)
+ RUBY_APPEND_OPTION(MJIT_DLDFLAGS_NOCOMPRESS, ${linker_flag}--compress-debug-sections=no)
])
AS_CASE(["$target_os"],[mingw*], [
@@ -2470,6 +2471,7 @@ AC_SUBST(MJIT_CC, [${MJIT_CC-'$(CC)'}])dnl
AC_SUBST(MJIT_OPTFLAGS, [${MJIT_OPTFLAGS-'$(optflags)'}])dnl
AC_SUBST(MJIT_DEBUGFLAGS, [${MJIT_DEBUGFLAGS-'$(debugflags)'}])dnl
AC_SUBST(MJIT_LDSHARED)dnl
+AC_SUBST(MJIT_DLDFLAGS_NOCOMPRESS)dnl
AC_SUBST(STATIC)dnl
AC_SUBST(CCDLFLAGS)dnl