aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
author卜部昌平 <shyouhei@ruby-lang.org>2020-08-22 14:12:12 +0900
committer卜部昌平 <shyouhei@ruby-lang.org>2020-08-22 14:12:12 +0900
commit2ddc67ffb6bd62550343db909bf5672d6d523682 (patch)
tree47a96a4b1e3bd1905a5be307f1a8007382ba4f62 /configure.ac
parent331d02038ba282c563f1705a5b0715f35a085b31 (diff)
downloadruby-2ddc67ffb6bd62550343db909bf5672d6d523682.tar.gz
configure.ac: suppress more Sun C warnings.
They are rather annoying than being useful to us.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5f16c12b15..37b4c53815 100644
--- a/configure.ac
+++ b/configure.ac
@@ -630,8 +630,17 @@ AC_COMPILE_IFELSE([
@%:@if !(defined(__SUNPRO_C)||defined(__SUNPRO_CC))
@%:@error not sunpro
@%:@endif],[])], [
- RUBY_TRY_CFLAGS(-erroff=E_STATEMENT_NOT_REACHED, [
- RUBY_APPEND_OPTIONS(rb_cv_warnflags, -erroff=E_STATEMENT_NOT_REACHED)])],[])
+ for e in \
+ E_STATEMENT_NOT_REACHED \
+ E_INIT_SIGN_EXTEND \
+ E_INIT_DOES_NOT_FIT \
+ E_INITIALIZATION_TYPE_MISMATCH
+ do
+ RUBY_TRY_CFLAGS([-erroff=${e}], [
+ RUBY_APPEND_OPTIONS(rb_cv_warnflags, [-erroff=${e}])
+ ])
+ done
+])
AC_ARG_WITH(compress-debug-sections,
AS_HELP_STRING([--with-compress-debug-sections=type],