aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTakashi Kokubun <takashikkbn@gmail.com>2022-12-14 00:12:55 -0800
committerTakashi Kokubun <takashikkbn@gmail.com>2023-03-05 22:11:20 -0800
commit3fa4d41460f67791d08d9bec2f8add9dd15f0f07 (patch)
tree730bcfa47eebfa2371adea5d5956253fc49f0cee /configure.ac
parentfd04e1b4dbbb0dae130f3de79d69ca94ecdf883e (diff)
downloadruby-3fa4d41460f67791d08d9bec2f8add9dd15f0f07.tar.gz
Implement --mjit-dump-disasm
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 70946f83d8..64f0a48435 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3855,6 +3855,12 @@ AS_CASE(["${YJIT_SUPPORT}"],
AC_DEFINE(USE_YJIT, 1)
], [AC_DEFINE(USE_YJIT, 0)])
+# If YJIT links capstone, libcapstone stops working on the C side.
+# capstone should be linked for MJIT only when YJIT doesn't.
+AS_IF([test x"$MJIT_SUPPORT" = "xyes" -a -z "$CARGO_BUILD_ARGS" ], [
+ AC_CHECK_LIB([capstone], [cs_disasm])
+])
+
dnl These variables end up in ::RbConfig::CONFIG
AC_SUBST(YJIT_SUPPORT)dnl what flavor of YJIT the Ruby build includes
AC_SUBST(RUSTC)dnl Rust compiler command