aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKoichi Sasada <ko1@atdot.net>2023-10-15 03:56:46 +0900
committerKoichi Sasada <ko1@atdot.net>2023-10-15 04:35:17 +0900
commit55c5ebe0a02eee319eb6a965a08bb53c5dcc7feb (patch)
treefdd002f6addcc4086b2bdd33552a73534cb39c47 /configure.ac
parent7865cebfb7a113ed87409a41424c4fd617dee67c (diff)
downloadruby-55c5ebe0a02eee319eb6a965a08bb53c5dcc7feb.tar.gz
disable MN threads on s390s-linux
I check the s390s-linux/Ubuntu system and I found that MN threads doesn't work with: * function inlining (-O0 doesn't repro) * Thread local specifier (`_Thread_local`. With `pthread_get_specific works) (it is not an issue of `__tls_get_addr()` written in thread.c) * swap context with ucontext (coroutine/ucontext) I couldn't find out what is the root cause of this issue but disable MN threads to make CI healthy.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 71f831636c..b878e5cbde 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4364,6 +4364,10 @@ AS_IF([test "${universal_binary-no}" = yes ], [
arch="${target_cpu}-${target_os}"
])
AC_DEFINE_UNQUOTED(RUBY_PLATFORM, "$arch")
+
+ AS_IF([test "$arch" = "s390x-linux"], [
+ AC_DEFINE_UNQUOTED(USE_MN_THREADS, 0)
+ ])
])
unset sitearch