aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorYusuke Endoh <mame@ruby-lang.org>2020-11-27 17:51:07 +0900
committerYusuke Endoh <mame@ruby-lang.org>2020-11-27 19:53:21 +0900
commit5d8fe1267d2d4e60943e7b41f6dad990a53e077b (patch)
treeda9d0d7f910b31be7548ca69b0ff097b6c945608 /configure.ac
parentf0e2ea2859f9a51260f22b38fae1719a2eab59d9 (diff)
downloadruby-5d8fe1267d2d4e60943e7b41f6dad990a53e077b.tar.gz
configure.ac: Check x86intrin.h only when the target CPU is x86
The check output a warning on M1 Mac mini http://rubyci.s3.amazonaws.com/osx1100arm/ruby-master/log/20201127T074507Z.log.html.gz ``` checking x86intrin.h usability... no checking x86intrin.h presence... yes configure: WARNING: x86intrin.h: present but cannot be compiled configure: WARNING: x86intrin.h: check for missing prerequisite headers? configure: WARNING: x86intrin.h: see the Autoconf documentation configure: WARNING: x86intrin.h: section "Present But Cannot Be Compiled" configure: WARNING: x86intrin.h: proceeding with the compiler's result checking for x86intrin.h... no ```
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c2b1a078a0..6c6d73f11f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1204,7 +1204,9 @@ AC_CHECK_HEADERS(syscall.h)
AC_CHECK_HEADERS(time.h)
AC_CHECK_HEADERS(ucontext.h)
AC_CHECK_HEADERS(utime.h)
-AC_CHECK_HEADERS(x86intrin.h)
+AS_CASE("$target_cpu", [x64|x86_64|i[3-6]86*], [
+ AC_CHECK_HEADERS(x86intrin.h)
+])
AC_ARG_WITH([gmp],
[AS_HELP_STRING([--without-gmp],