aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-09-20 14:30:21 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-09-20 14:30:21 +0000
commit69ac3060bd331d165068b7cd150dbd526dcf3034 (patch)
treef58cc0952266990bc6398bfe101db0d5f95e1a06 /configure.ac
parentc34cd91d92c98131f52ffe8e2e6d2f0b79e13d1e (diff)
downloadruby-69ac3060bd331d165068b7cd150dbd526dcf3034.tar.gz
Ignore Xcode linker warnings
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@64793 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 14fe5279c7..bfe7c19ce8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -397,6 +397,11 @@ RUBY_WERROR_FLAG([
AC_MSG_ERROR([something wrong with CFLAGS="$CFLAGS"])
]
)
+
+ # now Xcode linker warns for deprecated architecture and wrongly
+ # installed TBD files.
+ AS_CASE(["$target_os"], [darwin*], [ac_c_werror_flag=])
+
AC_MSG_CHECKING([whether LDFLAGS is valid])
{
mkdir tmp.$$.try_link &&