aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNaohisa Goto <ngotogenome@gmail.com>2020-12-21 23:08:35 +0900
committerNaohisa Goto <ngotogenome@gmail.com>2020-12-21 23:42:34 +0900
commit84eebb3c9e92d33055393d32a276e11f3e1afd3f (patch)
treeec2813192dfc7c171f5e29004a599b9ee89fac04 /configure.ac
parent91e2f08a6a296acb7debb184ffe1229c5c25bb0c (diff)
downloadruby-84eebb3c9e92d33055393d32a276e11f3e1afd3f.tar.gz
On Solaris, _XOPEN_SOURCE should be undefined for C++ sources.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dbd08321bd..c3157ff0fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1034,6 +1034,8 @@ main()
AC_MSG_RESULT($define_xopen_source)
AS_IF([test x"$define_xopen_source" != xno], [
RUBY_APPEND_OPTIONS(CPPFLAGS, -D_XOPEN_SOURCE=$define_xopen_source)
+ # _XOPEN_SOURCE should not be defined for C++ on Solaris.
+ RUBY_APPEND_OPTIONS(CXXFLAGS, -U_XOPEN_SOURCE)
])
])
],