aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorYusuke Endoh <mame@ruby-lang.org>2020-12-11 10:54:06 +0900
committerYusuke Endoh <mame@ruby-lang.org>2020-12-11 14:08:23 +0900
commit8c5ec10038a9bbc328eeb3756da207ba5976072d (patch)
treed7ffe32722763de1cc27cae93ebd4235c7953303 /configure.ac
parent288e93bea872e99ccf706294dc63b8a2b139ea2c (diff)
downloadruby-8c5ec10038a9bbc328eeb3756da207ba5976072d.tar.gz
Link zlib always if available
Major Linux distribution packages including Debian, Ubuntu, and Fedora use `--compress-debug-sections=no` to build ruby, and then extract and compress debug symbols as separate files. However, the configure option makes ruby not link zlib, thus the generated binary cannot uncompress the compressed separate debug symbol files, and fails to show C level backtrace when a critical error like segfault occurs. This change makes ruby always link zlib if it is available so that it can show C level backtrace correctly. Related: Debian packages require https://github.com/ruby/ruby/pull/3627 to load debug symbol files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 6c6d73f11f..1ab36e8d0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2739,9 +2739,7 @@ AS_IF([test "$rb_cv_binary_elf" = yes], [
AC_CHECK_HEADERS([elf.h elf_abi.h])
AS_IF([test $ac_cv_header_elf_h = yes -o $ac_cv_header_elf_abi_h = yes], [
AC_LIBOBJ([addr2line])
- AS_IF([test "x$compress_debug_sections" = xzlib], [
- AC_CHECK_LIB([z], [uncompress])
- ])
+ AC_CHECK_LIB([z], [uncompress])
])
])