aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHiroshi SHIBATA <hsbt@ruby-lang.org>2023-07-07 09:16:15 +0900
committerHiroshi SHIBATA <hsbt@ruby-lang.org>2023-07-07 09:28:27 +0900
commita642a94b68a31c0e7c092087114c269132cdb159 (patch)
tree584a0b692ac63c904b488ac8def2d44038ded13e /configure.ac
parent48d95de6a61230d8364952a18ea123e86b3525e5 (diff)
downloadruby-a642a94b68a31c0e7c092087114c269132cdb159.tar.gz
llvm-objcopy is not provided by Xcode Command Line Tools.
Revert "Disable YJIT if objcopy command is old" This reverts commit 75f8781c08da421d6bcfb2c3c8b7b74efea3bec2.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 2 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 54e28e9dc8..0b01430db1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3790,23 +3790,13 @@ AS_IF([test "$cross_compiling" = no],
)
)
-dnl Needs newer objcopy in order to localize symbols added by rustc
-YJIT_OBJCOPY_OK=no
-AS_CASE(["$OBJCOPY"], [""|:], [], [
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[]])], [
- AS_IF([$OBJCOPY --wildcard --keep-global-symbol='*main' --localize-symbol='__*' conftest.$OBJEXT 2>/dev/null], [
- YJIT_OBJCOPY_OK=yes
- ])
- ])
-])
-
dnl build YJIT in release mode if rustc >= 1.58.0 is present and we are on a supported platform
AC_ARG_ENABLE(yjit,
AS_HELP_STRING([--enable-yjit],
[enable in-process JIT compiler that requires Rust build tools. enabled by default on supported platforms if rustc 1.58.0+ is available]),
[YJIT_SUPPORT=$enableval],
- [AS_CASE(["$YJIT_TARGET_OK:$YJIT_RUSTC_OK:$YJIT_OBJCOPY_OK"],
- [yes:yes:yes], [
+ [AS_CASE(["$YJIT_TARGET_OK:$YJIT_RUSTC_OK"],
+ [yes:yes], [
YJIT_SUPPORT=yes
],
[YJIT_SUPPORT=no]
@@ -3821,9 +3811,6 @@ AS_CASE(["${YJIT_SUPPORT}"],
AS_IF([test x"$RUSTC" = "xno"],
AC_MSG_ERROR([rustc is required. Installation instructions available at https://www.rust-lang.org/tools/install])
)
- AS_IF([test x"$YJIT_OBJCOPY_OK" = yno],
- AC_MSG_ERROR([$OBJCOPY does not recognize --wildcard option or something])
- )
AS_CASE(["${YJIT_SUPPORT}"],
[yes], [