aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2023-08-17 12:18:01 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2023-08-17 16:30:01 +0900
commitd26b015e83e499e3bad61d6f2ef88eeca55fdedc (patch)
tree7db00700f93fbe07c64362a0a177cb7e10960716 /configure.ac
parente210b899dc803607bef1b395ace02dc9f96554ea (diff)
downloadruby-d26b015e83e499e3bad61d6f2ef88eeca55fdedc.tar.gz
[Bug #19831] Remove duplicate library options
`$(LIBRUBYARG_SHARED)` is included in `$(LIBS)` in extension libraries.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index caacfebbed..f71c2c2609 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3061,8 +3061,7 @@ AC_SUBST(EXTOBJS)
: ${LIBPATHENV=DYLD_FALLBACK_LIBRARY_PATH}
: ${PRELOADENV=DYLD_INSERT_LIBRARIES}
AS_IF([test x"$enable_shared" = xyes], [
- # Resolve symbols from libruby.dylib when --enable-shared
- EXTDLDFLAGS='$(LIBRUBYARG_SHARED)'
+ # Resolve symbols from libruby.dylib in $(LIBS) when --enable-shared
], [test "x$EXTSTATIC" = x], [
# When building exts as bundles, a mach-o bundle needs to know its loader
# program to bind symbols from the ruby executable