aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-06-30 11:56:54 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-06-30 11:56:54 +0000
commitee8824776942b64ac6947d4bd63b4d22d8461916 (patch)
tree4d59b0d767eebfe93008b2ba46af9662362350fa /configure.ac
parenta3a325e5a321d0c8f5f80e9cabfd02b3e8839c81 (diff)
downloadruby-ee8824776942b64ac6947d4bd63b4d22d8461916.tar.gz
use sigsetjmp on macOS
SIGCHLD is used internally since r63758, the signal masks need to be restored. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@63803 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f48db0733c..6b6dd0b9ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -766,6 +766,7 @@ AS_CASE(["$target_os"],
AS_IF([test $gcc_major -lt 4 -o \( $gcc_major -eq 4 -a $gcc_minor -lt 3 \)], [
ac_cv_func___builtin_setjmp=no
])
+ with_setjmp_type=sigsetjmp # to hijack SIGCHLD handler
AC_CACHE_CHECK(for broken crypt with 8bit chars, rb_cv_broken_crypt,
[AC_TRY_RUN([
#include <stdio.h>