aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJean Boussier <byroot@ruby-lang.org>2023-09-15 16:22:09 +0200
committerJean Boussier <jean.boussier@gmail.com>2023-09-15 17:45:21 +0200
commitefe2822708d62bfe3ba858da526e6ef7d4724959 (patch)
treecafd2cc6bdbd6653a8fe1926911f1cd9c16e3a27 /configure.ac
parent28fe88468d7bde129221415bfa874f4b70bf6843 (diff)
downloadruby-efe2822708d62bfe3ba858da526e6ef7d4724959.tar.gz
Process.warmup: invoke `malloc_trim` if available
Similar to releasing free GC pages, releasing free malloc pages reduce the amount of page faults post fork.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 30a1350fa6..70400dd797 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2078,6 +2078,7 @@ AC_CHECK_FUNCS(lstat)
AC_CHECK_FUNCS(lutimes)
AC_CHECK_FUNCS(malloc_usable_size)
AC_CHECK_FUNCS(malloc_size)
+AC_CHECK_FUNCS(malloc_trim)
AC_CHECK_FUNCS(mblen)
AC_CHECK_FUNCS(memalign)
AC_CHECK_FUNCS(memset_s)