aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2023-09-15 12:08:25 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2023-09-15 13:27:19 +0900
commitfe0225ff4d5af8b1f54009727b39d0d9b821eea3 (patch)
treea9fac9d6c2afe74516d03be279679a8a92e8680e /configure.ac
parent74277f999841834ec6765369d20e514e09aecc4e (diff)
downloadruby-fe0225ff4d5af8b1f54009727b39d0d9b821eea3.tar.gz
[Bug #19778] Add `-I` options for opt-dir to `$INCFLAGS`
These options have been separated from `$CFLAGS` already in the other places.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 122e061792..30a1350fa6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -967,7 +967,7 @@ AS_IF([test "x$OPT_DIR" != x], [
LDFLAGS="${LDFLAGS:+$LDFLAGS }$val"
DLDFLAGS="${DLDFLAGS:+$DLDFLAGS }$val"
LDFLAGS_OPTDIR="$val"
- CPPFLAGS="${CPPFLAGS:+$CPPFLAGS }"`echo "$OPT_DIR" | tr "${PATH_SEPARATOR}" '\012' |
+ INCFLAGS="${INCFLAGS:+$INCFLAGS }"`echo "$OPT_DIR" | tr "${PATH_SEPARATOR}" '\012' |
sed '/^$/d;s|^|-I|;s|$|/include|' | tr '\012' ' ' | sed 's/ *$//'`
])