aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authork0kubun <k0kubun@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-08-12 15:16:00 +0000
committerk0kubun <k0kubun@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-08-12 15:16:00 +0000
commitd6b3dc1f6fd7f87266e1cd1667afbb108cd2ec95 (patch)
treee0605e1284c0180e8a272f7af9382ecc3ab69fe4 /configure.ac
parent23cbcbc71e048360658b58a9741070b1e335926a (diff)
downloadruby-d6b3dc1f6fd7f87266e1cd1667afbb108cd2ec95.tar.gz
configure.ac: use the correct argument
for --compress-debug-sections. I thought "no" is the correct one because configure.ac has `AS_IF([test "x$compress_debug_sections" != xno]`, but it wasn't the case. This commit is needed to resolve errors like: /usr/bin/x86_64-linux-gnu-ld: invalid --compress-debug-sections option: `no' collect2: error: ld returned 1 exit status git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@64326 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8db1c90701..358acbe261 100644
--- a/configure.ac
+++ b/configure.ac
@@ -543,7 +543,7 @@ AS_IF([test "$GCC" = yes], [
])
AS_IF([test "x$compress_debug_sections" != xno], [
RUBY_APPEND_OPTION(DLDFLAGS, ${linker_flag}--compress-debug-sections=$compress_debug_sections)
- RUBY_APPEND_OPTION(MJIT_DLDFLAGS_NOCOMPRESS, ${linker_flag}--compress-debug-sections=no)
+ RUBY_APPEND_OPTION(MJIT_DLDFLAGS_NOCOMPRESS, ${linker_flag}--compress-debug-sections=none)
])
AS_CASE(["$target_os"],[mingw*], [